summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-03-02 16:48:22 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-03-02 16:48:22 (GMT)
commita1860aaf1a7f55d9eeb6b6dc54bf96774eb15bdf (patch)
treee56ecc8db3c674442e72804dcedba3df2f477167 /Tests/CMakeLists.txt
parent2fb1df42a25ef922a81d03d85317954ed5cfe8bf (diff)
parent5e1a5c44da395f8b2c121789e81f4a360a4088bc (diff)
downloadCMake-a1860aaf1a7f55d9eeb6b6dc54bf96774eb15bdf.zip
CMake-a1860aaf1a7f55d9eeb6b6dc54bf96774eb15bdf.tar.gz
CMake-a1860aaf1a7f55d9eeb6b6dc54bf96774eb15bdf.tar.bz2
Merge topic 'test-CMakeCommands'
5e1a5c4 Add infrastructure for CMakeCommands tests
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 654538e..00cac94 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -53,6 +53,7 @@ IF(BUILD_TESTING)
ADD_SUBDIRECTORY(CMakeLib)
ADD_SUBDIRECTORY(CMakeOnly)
+ ADD_SUBDIRECTORY(CMakeCommands)
ADD_SUBDIRECTORY(FindPackageModeMakefileTest)
@@ -1710,13 +1711,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
add_config_tests(Release)
add_config_tests(RelWithDebInfo)
- add_test(CMakeCommands.build_command ${CMAKE_CMAKE_COMMAND}
- -DCMake_SOURCE_DIR=${CMake_SOURCE_DIR}
- -Ddir=${CMake_BINARY_DIR}/Tests/CMakeCommands/build_command
- -Dgen=${CMAKE_TEST_GENERATOR}
- -P "${CMake_SOURCE_DIR}/Tests/CMakeCommands/build_command/RunCMake.cmake"
- )
-
ADD_TEST_MACRO(CMakeCommands.target_link_libraries target_link_libraries)
CONFIGURE_FILE(