summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-10-21 19:08:07 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-10-21 19:08:07 (GMT)
commit95d84f76d9a8e27eb974fce7d06b7f2e312a05e6 (patch)
tree727105aeb6ebba64c18a3af64c207e50cf900104 /Tests/CMakeLists.txt
parentc8ba39719409dc106f76c0b67f805158be01b3b4 (diff)
parent29c3edb87adedd82e816552d958f4c3540a1511b (diff)
downloadCMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.zip
CMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.tar.gz
CMake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.tar.bz2
Merge topic 'cmake-cmp0054-warnings'
29c3edb8 Avoid if() quoted auto-dereference
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 46f7b89..e1e90a1 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1501,7 +1501,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
set_tests_properties ( SimpleInstall-Stage2 PROPERTIES DEPENDS SimpleInstall)
# Test static linking on toolchains known to support it.
- if("${CMAKE_C_COMPILER_ID}" MATCHES "^(GNU)$"
+ if(CMAKE_C_COMPILER_ID STREQUAL "GNU"
AND NOT APPLE AND NOT WIN32 AND NOT CYGWIN
AND EXISTS "/usr/lib/libm.a")
add_test(LinkStatic ${CMAKE_CTEST_COMMAND}