summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-10-14 18:18:47 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-10-14 18:18:47 (GMT)
commita85ac1a7346c60a31e43c4b75e4e5b17cb0b6525 (patch)
tree3885446635052d9a9eab74e0945382dba52ae12e /Tests/CMakeLists.txt
parent2137955138d7d97fbd2e0dc1ef16a844552a101e (diff)
downloadCMake-a85ac1a7346c60a31e43c4b75e4e5b17cb0b6525.zip
CMake-a85ac1a7346c60a31e43c4b75e4e5b17cb0b6525.tar.gz
CMake-a85ac1a7346c60a31e43c4b75e4e5b17cb0b6525.tar.bz2
Use macro instead of function since DASH2 continuous dashboard still uses CMake 2.4.8 to drive the dashboard. Add clarifying comments so that a future developer does not delete seemingly unused variables: they are used: inside the input to the configure_file call.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index aa1f607..f28dfdb 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1113,11 +1113,20 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
ADD_TEST(CTestTestShowOnly ${CMAKE_CTEST_COMMAND} -N)
- function(add_failed_submit_test name source build in out log regex)
+ # Use macro, not function so that build can still be driven by CMake 2.4.
+ # After 2.6 is required, this could be a function without the extra 'set'
+ # calls.
+ #
+ macro(add_failed_submit_test name source build in out log regex)
+ # Have variables named source, build and drop_method because the
+ # configure_file call expects those variables to be defined.
+ #
+ set(source "${source}")
+ set(build "${build}")
configure_file("${in}" "${out}" @ONLY)
add_test(${name} ${CMAKE_CTEST_COMMAND} -S "${out}" -V --output-log "${log}")
set_tests_properties(${name} PROPERTIES PASS_REGULAR_EXPRESSION "${regex}")
- endfunction()
+ endmacro()
set(regex "(Problems when submitting via S*CP")
set(regex "${regex}|Error message was: ")