summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-17 20:15:34 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-17 20:15:34 (GMT)
commit11e6b513c2d642628e047369773188b0d485c581 (patch)
tree458ab7ebe45db0fc8dc3bb25e5657ae02f640b68 /Tests/CMakeLists.txt
parentc9b726c314c9c399975fbea3c673852310ee45e6 (diff)
downloadCMake-11e6b513c2d642628e047369773188b0d485c581.zip
CMake-11e6b513c2d642628e047369773188b0d485c581.tar.gz
CMake-11e6b513c2d642628e047369773188b0d485c581.tar.bz2
Test the CheckTypeSize module
We create test "Module.CheckTypeSize" to verify that type sizes get detected correctly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 0081a6e..4c6b333 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -172,6 +172,8 @@ IF(BUILD_TESTING)
"${CMake_BINARY_DIR}/Tests/CMakeBuildTest.cmake")
LIST(APPEND TEST_BUILD_DIRS ${CMAKE_BUILD_TEST_BINARY_DIR})
+ ADD_TEST_MACRO(Module.CheckTypeSize CheckTypeSize)
+
# If we are running right now with a UnixMakefiles based generator,
# build the "Simple" test with the ExtraGenerators, if available
# This doesn't test whether the generated project files work (unfortunately),