summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2010-08-31 14:41:23 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2010-08-31 14:41:23 (GMT)
commit32242affea45eb3c3ffa2691657e970eaac49799 (patch)
tree6d75ae8b204aac75d8b8baae644e14f4f88557e5 /Tests/CMakeLists.txt
parentaac1680648634a87dd4eee3ae603aef387798244 (diff)
downloadCMake-32242affea45eb3c3ffa2691657e970eaac49799.zip
CMake-32242affea45eb3c3ffa2691657e970eaac49799.tar.gz
CMake-32242affea45eb3c3ffa2691657e970eaac49799.tar.bz2
Added CTest command --print-labels
This command allows a user to quickly see the list of all available test labels. The labels are also printed in verbose show only mode, alongside their corresponding tests.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5383bda..8e8d0ca 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1315,6 +1315,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--output-log "${CMake_BINARY_DIR}/Tests/CTestTestParallel/testOutput.log"
)
+ ADD_TEST(CTestTestPrintLabels ${CMAKE_CTEST_COMMAND} --print-labels)
+ SET_TESTS_PROPERTIES(CTestTestPrintLabels PROPERTIES LABELS "Label1;Label2")
+ SET_TESTS_PROPERTIES(CTestTestPrintLabels PROPERTIES PASS_REGULAR_EXPRESSION
+ "All Labels:.* Label1.* Label2")
+
CONFIGURE_FILE(
"${CMake_SOURCE_DIR}/Tests/CTestTestResourceLock/test.cmake.in"
"${CMake_BINARY_DIR}/Tests/CTestTestResourceLock/test.cmake"