summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-10 15:34:36 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-10 15:34:36 (GMT)
commit6c79c96265e43416fbc8130e701830389ae6c01a (patch)
tree8380af51a36bac12e81e574f1ab63b7d178f07cb /Tests/CMakeLists.txt
parent9d823f78479b19a739c3bb9037a0f72f3a65535c (diff)
downloadCMake-6c79c96265e43416fbc8130e701830389ae6c01a.zip
CMake-6c79c96265e43416fbc8130e701830389ae6c01a.tar.gz
CMake-6c79c96265e43416fbc8130e701830389ae6c01a.tar.bz2
Test 'install' target of CMake itself
We create option CMake_TEST_INSTALL to enable a new CMake.Install test. It tests running the "make install" target to install CMake itself into a test directory. We enable the option by default for dashboard builds.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5fa4059..3694daf 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -160,6 +160,8 @@ IF(BUILD_TESTING)
PASS_REGULAR_EXPRESSION "(file is not of required architecture|does not match cputype)")
ENDIF(CTEST_TEST_OSX_ARCH)
+ LIST(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
+
SET(CMAKE_BUILD_TEST_SOURCE_DIR "${CMake_SOURCE_DIR}/Tests/COnly")
SET(CMAKE_BUILD_TEST_BINARY_DIR "${CMake_BINARY_DIR}/Tests/CMakeBuildCOnly")
CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CMakeBuildTest.cmake.in"