summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-09-13 19:56:06 (GMT)
committerBrad King <brad.king@kitware.com>2010-09-13 20:17:20 (GMT)
commita6b5ead62fb4e69c053d752570f4c8af24e41857 (patch)
tree293eb05765da0e3feaafe4611bb1741f9fb85fed /Tests/CMakeLists.txt
parentf3bc219adbbf10f3a75af1ac1db1f47b90102e19 (diff)
downloadCMake-a6b5ead62fb4e69c053d752570f4c8af24e41857.zip
CMake-a6b5ead62fb4e69c053d752570f4c8af24e41857.tar.gz
CMake-a6b5ead62fb4e69c053d752570f4c8af24e41857.tar.bz2
Report missing source files with context of target
Previously we reported only the CMakeLists.txt file in the directory that adds the target.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8e8d0ca..3e92bdf 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -129,6 +129,9 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(MathTest MathTest)
ADD_TEST_MACRO(Simple Simple)
ADD_TEST_MACRO(PreOrder PreOrder)
+ ADD_TEST_MACRO(MissingSourceFile MissingSourceFile)
+ SET_TESTS_PROPERTIES(MissingSourceFile PROPERTIES
+ PASS_REGULAR_EXPRESSION "CMake Error at CMakeLists.txt:3 \\(add_executable\\):[ \r\n]*Cannot find source file \"MissingSourceFile.c\"")
ADD_TEST_MACRO(COnly COnly)
ADD_TEST_MACRO(CxxOnly CxxOnly)
ADD_TEST_MACRO(IPO COnly/COnly)