summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorModestas Vainius <modax@debian.org>2010-07-29 15:39:29 (GMT)
committerBrad King <brad.king@kitware.com>2010-07-29 15:39:29 (GMT)
commitfbe67a9fda7c3a96a1774838cb13353b79443e56 (patch)
treead4d8531a4c672800ecef9158095784a8cce3bee /Tests/CMakeLists.txt
parent03b7eff0eacc2b80a85b949eb8031cb5e7a3d393 (diff)
downloadCMake-fbe67a9fda7c3a96a1774838cb13353b79443e56.zip
CMake-fbe67a9fda7c3a96a1774838cb13353b79443e56.tar.gz
CMake-fbe67a9fda7c3a96a1774838cb13353b79443e56.tar.bz2
CTestTestFailedSubmit-xmlrpc: Pass with "Submission problem"
Pass the test when there is "Submission problem" in the output. This is at least applicable to XMLRPC. Full error message is below: ------ Submission problem: Curl failed to perform HTTP POST request. curl_easy_perform() says: <url> malformed (-504) . Problems when submitting via XML-RPC ------
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9865134..bd4ccf9 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1436,6 +1436,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
set(regex "${regex}|The requested URL returned error")
set(regex "${regex}|libcurl was built with SSL disabled. https: not supported)")
set(regex "${regex}|Submission method .xmlrpc. not compiled into CTest")
+ set(regex "${regex}|Submission problem")
set(regex "${regex}|Submission successful)")
set(ctest_coverage_labels_args "")