summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-08-24 18:24:24 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-08-24 18:24:24 (GMT)
commit05784dadc59ee3c87ab6140d684ff4c602de9ec1 (patch)
treedbaac2b00fb70a112a9e1ee71323c5c224bde6b9 /Tests/CMakeLists.txt
parent286f7c9644d1fb8ac8b5d46e2a3c9c393680acef (diff)
parentf0a1065393a57f503bc2c86f432f50dd4b8d5bbd (diff)
downloadCMake-05784dadc59ee3c87ab6140d684ff4c602de9ec1.zip
CMake-05784dadc59ee3c87ab6140d684ff4c602de9ec1.tar.gz
CMake-05784dadc59ee3c87ab6140d684ff4c602de9ec1.tar.bz2
Merge topic 'compile-definitions-unique'
f0a1065 Rename files from main.cpp to more meaningful names. ca7fb14 Fix the test setting COMPILE_DEFINITIONS target property 733deb6 Fix CompileDefinitions test on Visual Studio. 3dae652 Don't duplicate -D defines sent to the compiler.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 35a8d41..e03b926 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -213,6 +213,7 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(Unset Unset)
ADD_TEST_MACRO(PolicyScope PolicyScope)
ADD_TEST_MACRO(EmptyLibrary EmptyLibrary)
+ ADD_TEST_MACRO(CompileDefinitions CompileDefinitions)
set_tests_properties(EmptyLibrary PROPERTIES
PASS_REGULAR_EXPRESSION "CMake Error: CMake can not determine linker language for target:test")
ADD_TEST_MACRO(CrossCompile CrossCompile)