summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-04-22 15:16:43 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-04-22 15:16:43 (GMT)
commit1468f31988593abdf513e873138a49d758ce8a1c (patch)
tree08e4a7169734a49e3123ccf51bcc57e5f9f51b00 /Tests/CMakeLists.txt
parent8f9539287903e514567cf3dfac9636445b3fafa1 (diff)
parentb470d618644808d5d2db20e5bbc09a1d22bf486d (diff)
downloadCMake-1468f31988593abdf513e873138a49d758ce8a1c.zip
CMake-1468f31988593abdf513e873138a49d758ce8a1c.tar.gz
CMake-1468f31988593abdf513e873138a49d758ce8a1c.tar.bz2
Merge topic 'ExternalProject-genex'
b470d618 Help: Add notes for topic 'ExternalProject-genex' 0273ef14 ExternalProject: Allow generator expressions with LOG_* options (#15287) 7bd8cfb8 ExternalProject: Allow generator expressions in initial cache options 1cf43dcf Tests: Add case to cover ExternalProject with subdirectories
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index d568a64..eb4dd6b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1326,6 +1326,18 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
set_tests_properties(ExternalProject PROPERTIES
TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
+ add_test(NAME ExternalProjectSubdir
+ COMMAND ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/ExternalProjectSubdir"
+ "${CMake_BINARY_DIR}/Tests/ExternalProjectSubdir"
+ ${build_generator_args}
+ --build-project ExternalProjectSubdir
+ --force-new-ctest-process
+ --build-options ${build_options}
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/ExternalProjectSubdir")
+
add_test(ExternalProjectLocal ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/ExternalProjectLocal"