summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-10-15 17:56:07 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2008-10-15 17:56:07 (GMT)
commit1777bb502a3c8dbcead54b11fe403e13fe9c225c (patch)
treee85da2c575bc1e88254287b220e4e236065f3285 /Tests/CMakeLists.txt
parente099dccf4b3772c10c076ec1044dae01da510d28 (diff)
downloadCMake-1777bb502a3c8dbcead54b11fe403e13fe9c225c.zip
CMake-1777bb502a3c8dbcead54b11fe403e13fe9c225c.tar.gz
CMake-1777bb502a3c8dbcead54b11fe403e13fe9c225c.tar.bz2
BUG: 4244, add a --build option to cmake that can build projects configured by CMake
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 14366b3..336ccf0 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -96,6 +96,12 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(ExportImport ExportImport)
ADD_TEST_MACRO(Unset Unset)
+ SET(CMAKE_BUILD_TEST_SOURCE_DIR "${CMake_SOURCE_DIR}/Tests/COnly")
+ SET(CMAKE_BUILD_TEST_BINARY_DIR "${CMake_BINARY_DIR}/Tests/CMakeBuildCOnly")
+ CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CMakeBuildTest.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CMakeBuildTest.cmake" @ONLY)
+ ADD_TEST(CMakeBuildTest ${CMAKE_CMAKE_COMMAND} -P
+ "${CMake_BINARY_DIR}/Tests/CMakeBuildTest.cmake")
# If we are running right now with a UnixMakefiles based generator,
# build the "Simple" test with the ExtraGenerators, if available