summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-04 13:48:13 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-09-04 13:48:13 (GMT)
commit1e88ab62e84bc9b23de4c58134a8dd1f86942a82 (patch)
tree5e5e55134ef4842f9324560f99244ac6f73c2f06 /Tests/CMakeLists.txt
parent13e4e0a831aa106ad2832b8dde8f89f6134f1eb4 (diff)
parent4952030c2e5dba694ef4e7071a296fee07a19f1f (diff)
downloadCMake-1e88ab62e84bc9b23de4c58134a8dd1f86942a82.zip
CMake-1e88ab62e84bc9b23de4c58134a8dd1f86942a82.tar.gz
CMake-1e88ab62e84bc9b23de4c58134a8dd1f86942a82.tar.bz2
Merge topic 'wix-log-on-failure'
4952030c CPackWiX: Attach wix.log on test failure.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index a091d40..7242a00 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -863,6 +863,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
"-DCPackWiXGenerator_BINARY_DIR:PATH=${CMake_BINARY_DIR}/Tests/CPackWiXGenerator"
"-Dconfig=\${CTEST_CONFIGURATION_TYPE}"
-P "${CMake_SOURCE_DIR}/Tests/CPackWiXGenerator/RunCPackVerifyResult.cmake")
+
+ set_property(TEST CPackWiXGenerator PROPERTY
+ ATTACHED_FILES_ON_FAIL
+ "${CMake_BINARY_DIR}/Tests/CPackWiXGenerator/_CPack_Packages/win32/WIX/wix.log")
endif()
endif()