summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2011-11-23 13:16:10 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-11-23 13:16:10 (GMT)
commit1ec3801a3ae3969b9530163b79209df26dd1bb45 (patch)
tree108173b4220e8a649200a69588816c39b3c3f1cd /Tests/CMakeLists.txt
parent57a85237ac8ebc429ebe442897169bc9369e0380 (diff)
parentb1f12f8042ef0d7b190c04644905d3b3a325d4ae (diff)
downloadCMake-1ec3801a3ae3969b9530163b79209df26dd1bb45.zip
CMake-1ec3801a3ae3969b9530163b79209df26dd1bb45.tar.gz
CMake-1ec3801a3ae3969b9530163b79209df26dd1bb45.tar.bz2
Merge topic 'target-link-libraries-interfaces'
b1f12f8 target_link_libraries: Simplify argument processing state tests 5fc95df target_link_libraries: Add missing space in documentation 9143822 target_link_libraries: Add LINK_(PUBLIC|PRIVATE) options cf64218 target_link_libraries: Trim trailing whitespace
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 28c6261..1851f7a 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1658,6 +1658,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
-P "${CMake_SOURCE_DIR}/Tests/CMakeCommands/build_command/RunCMake.cmake"
)
+ ADD_TEST_MACRO(CMakeCommands.target_link_libraries target_link_libraries)
+
CONFIGURE_FILE(
"${CMake_SOURCE_DIR}/Tests/CTestTestCrash/test.cmake.in"
"${CMake_BINARY_DIR}/Tests/CTestTestCrash/test.cmake"