summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-07-07 19:07:54 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2008-07-07 19:07:54 (GMT)
commit2081dcbfce7245a1c19ec1e5fb9f0a7a3780aa30 (patch)
treeed323ce4b9a8902ee6c5dcb9951863ba552ab8ac /Tests/CMakeLists.txt
parent9a3c0bf07308b89f2b13e877048bbb8f43717c6f (diff)
downloadCMake-2081dcbfce7245a1c19ec1e5fb9f0a7a3780aa30.zip
CMake-2081dcbfce7245a1c19ec1e5fb9f0a7a3780aa30.tar.gz
CMake-2081dcbfce7245a1c19ec1e5fb9f0a7a3780aa30.tar.bz2
ENH: add get_test_property to bootstrap so bootstrap builds test the same as non-bootstrap builds
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 472e2b3..f2601c8 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -12,16 +12,6 @@ MACRO(ADD_TEST_MACRO NAME COMMAND)
--test-command ${COMMAND})
ENDMACRO(ADD_TEST_MACRO)
-# Support bootstrap builds. When CMake 2.6 is required we can switch
-# to using the get_property command which is in bootstrap. Note that
-# that command will return empty instead of NOTFOUND if the property
-# is not set.
-IF(NOT COMMAND GET_TEST_PROPERTY)
- MACRO(GET_TEST_PROPERTY test prop var)
- SET(${var} "")
- ENDMACRO(GET_TEST_PROPERTY)
-ENDIF(NOT COMMAND GET_TEST_PROPERTY)
-
# Testing
IF(BUILD_TESTING)
# Should the long tests be run?