summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-03 17:39:30 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-03 20:26:48 (GMT)
commit3c01ee5adceafb0febd9cedab9211f830f953c03 (patch)
treee562cc2f1cd8991c7655e9f429718c6a71f94873 /Tests/CMakeLists.txt
parentdaf0a5fedebb2dac66ac26516eeeff502ddcf432 (diff)
downloadCMake-3c01ee5adceafb0febd9cedab9211f830f953c03.zip
CMake-3c01ee5adceafb0febd9cedab9211f830f953c03.tar.gz
CMake-3c01ee5adceafb0febd9cedab9211f830f953c03.tar.bz2
Tests: Drop CMAKE_TEST_MSVC and test MSVC directly
Now that we no longer support running tests using a different generator we can trust the MSVC platform indicator directly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index fa98a2b..9ca354d 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1497,12 +1497,12 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
endif ()
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/SubDir")
- if(CMAKE_TEST_MSVC)
+ if(MSVC)
ADD_TEST_MACRO(ForceInclude foo)
ADD_TEST_MACRO(PDBDirectoryAndName myexe)
ADD_TEST_MACRO(PrecompiledHeader foo)
endif()
- if(CMAKE_TEST_MSVC OR
+ if(MSVC OR
"${CMAKE_TEST_GENERATOR}" MATCHES "(MSYS|MinGW) Makefiles")
ADD_TEST_MACRO(ModuleDefinition example_exe)
endif()