summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-12-18 17:28:05 (GMT)
committerBrad King <brad.king@kitware.com>2008-12-18 17:28:05 (GMT)
commitadb6bf82b0c780f9fbf36ef5bebaa38d4e7eb5ae (patch)
treec5dd5da64149b2174712164ee5b2f02d72004aca /Tests/CMakeLists.txt
parent4c725d1e0ef60f55d7c6b628d9fcd4961f4f2115 (diff)
downloadCMake-adb6bf82b0c780f9fbf36ef5bebaa38d4e7eb5ae.zip
CMake-adb6bf82b0c780f9fbf36ef5bebaa38d4e7eb5ae.tar.gz
CMake-adb6bf82b0c780f9fbf36ef5bebaa38d4e7eb5ae.tar.bz2
ENH: Improve 'testing' test to actually test
The 'testing' CMake test builds a project that uses add_test. This strengthens the test to actually run CTest on the project build tree after building it.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5596663..8ae3041 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -537,15 +537,14 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
ENDFOREACH(STP)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Tutorial")
- ADD_TEST(testing ${CMAKE_CTEST_COMMAND}
+ ADD_TEST(testing ${CMAKE_CTEST_COMMAND} -C \${CTEST_CONFIGURATION_TYPE}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Testing"
"${CMake_BINARY_DIR}/Tests/Testing"
--build-generator ${CMAKE_TEST_GENERATOR}
--build-project Testing
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
- --build-exe-dir "${CMake_BINARY_DIR}/Tests/Testing/bin"
- --test-command testing
+ --test-command ${CMAKE_CTEST_COMMAND} -C \${CTEST_CONFIGURATION_TYPE}
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Testing")