summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2012-05-04 15:41:15 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2012-05-04 15:41:15 (GMT)
commitb0c07a13d1ee034875c2067f35bd39a9ffef7954 (patch)
tree25f8deb8dc4a6c3d058dd89d5007af5be29ffa1b /Tests/CMakeLists.txt
parent0a169e628bb222fec7deead87f6ebe8fa77c7805 (diff)
downloadCMake-b0c07a13d1ee034875c2067f35bd39a9ffef7954.zip
CMake-b0c07a13d1ee034875c2067f35bd39a9ffef7954.tar.gz
CMake-b0c07a13d1ee034875c2067f35bd39a9ffef7954.tar.bz2
Disable bullseye coverage for mumps coverage test.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index f2175fc..3f5dd2c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1725,7 +1725,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
$<TARGET_FILE:ctest> -T Coverage --debug)
set_tests_properties(CTestGTMCoverage PROPERTIES
PASS_REGULAR_EXPRESSION
- "Process file.*XINDEX.m.*Total LOC:.*127.*Percentage Coverage: 85.83.*")
+ "Process file.*XINDEX.m.*Total LOC:.*127.*Percentage Coverage: 85.83.*"
+ ENVIRONMENT COVFILE=)
configure_file(
"${CMake_SOURCE_DIR}/Tests/MumpsCoverage/DartConfiguration.cache.tcl.in"
@@ -1741,7 +1742,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
$<TARGET_FILE:ctest> -T Coverage --debug)
set_tests_properties(CTestCacheCoverage PROPERTIES
PASS_REGULAR_EXPRESSION
- "Process file.*XINDEX.m.*Total LOC:.*125.*Percentage Coverage: 85.60.*")
+ "Process file.*XINDEX.m.*Total LOC:.*125.*Percentage Coverage: 85.60.*"
+ ENVIRONMENT COVFILE=)
# Use macro, not function so that build can still be driven by CMake 2.4.
# After 2.6 is required, this could be a function without the extra 'set'
# calls.