summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-11-21 18:21:55 (GMT)
committerBrad King <brad.king@kitware.com>2014-12-02 15:56:36 (GMT)
commitb7d760aea20f70b221fcba7ecb2c7edf7751ffc2 (patch)
tree105bcbbb5bee7350ac2988704f6bb66a3aaa4ad4 /Tests/CMakeLists.txt
parent3350e4d209b6a7ff758ca371af4d62844a66ab36 (diff)
downloadCMake-b7d760aea20f70b221fcba7ecb2c7edf7751ffc2.zip
CMake-b7d760aea20f70b221fcba7ecb2c7edf7751ffc2.tar.gz
CMake-b7d760aea20f70b221fcba7ecb2c7edf7751ffc2.tar.bz2
test: test source file properties with case-insensitivity
Some filesystems are case insensitive, so when setting properties on the files, this should be respected (modulo a policy decision).
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index c9d9568..fda9359 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -291,6 +291,7 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(ConfigSources ConfigSources)
endif()
ADD_TEST_MACRO(SourcesProperty SourcesProperty)
+ ADD_TEST_MACRO(SourceFileProperty SourceFileProperty)
if(CMAKE_CXX_COMPILER_ID STREQUAL GNU
AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.7)
set(runCxxDialectTest 1)