summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-09 14:23:31 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-10-09 14:23:31 (GMT)
commite5f17214a522da70c52acf8394a029344c59b9d0 (patch)
treee15fba734396fa889287dcb13ed7755f8de874b6 /Tests/CMakeLists.txt
parent1c1a904328093933d6d228d8117e5fd7231defb2 (diff)
parent7efef02df29399d37b692e01fb69de63e558585b (diff)
downloadCMake-e5f17214a522da70c52acf8394a029344c59b9d0.zip
CMake-e5f17214a522da70c52acf8394a029344c59b9d0.tar.gz
CMake-e5f17214a522da70c52acf8394a029344c59b9d0.tar.bz2
Merge topic 'FindGTK2-targets'
7efef02 FindGTK2: Add tests for components and targets in gtk and gtkmm modules 95fc47a FindGTK2: Make pangocairo and cairo optional dependencies 26f790f FindGTK2: Change extra includes -> optional 24e0272 FindGTK2: do not skip target creation if optional dependencies are not found d5f130c FindGTK2: Refactor _GTK2_ADJUST_LIB_VARS into _GTK2_ADD_TARGET fffbd72 FindGTK2: Do not add freetype includes if they are not found b69720d FindGTK2: Add libraries to the GTK2_LIBRARIES variable only when found 425ec40 FindGTK2: Do not link libfreetype e9f46df FindGTK2: Add config directories only if different from include ones 56a79e1 FindGTK2: Set INTERFACE_COMPILE_DEFINITIONS target property only if not empty 4b47586 FindGTK2: Add check to ensure that target exists 61242cc FindGTK2: Fix gmodule, glibmm, pangoft2, and pangoxft targets 4b876de FindGTK2: Link freetype libs to targets including freetype includes 67e761f FindGTK2: Small cleanup 682eea3 FindGTK2: Do not require the GTK_ prefix in all the internal functions 0bc3763 FindGTK2: Better handling of include directories ...
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9afc112..f7b98da 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1072,6 +1072,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
endif()
endif()
+ find_package(GTK2 QUIET)
+ if(GTK2_FOUND)
+ add_subdirectory(FindGTK2)
+ endif()
+
add_test(ExternalProject ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/ExternalProject"