summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-01-07 23:34:41 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-10 14:46:58 (GMT)
commitfc61a7a746c3c899d42ccff3014686365c36ee11 (patch)
tree1a8079e72ae1d66b8f73303fb12f73e696aa1e86 /Tests/CMakeLists.txt
parent8a37ebec784cefe4f04cb8897c23a014c3930052 (diff)
downloadCMake-fc61a7a746c3c899d42ccff3014686365c36ee11.zip
CMake-fc61a7a746c3c899d42ccff3014686365c36ee11.tar.gz
CMake-fc61a7a746c3c899d42ccff3014686365c36ee11.tar.bz2
Add the target_compile_definitions command.
This is a convenience API to populate the corresponding properties.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2dced5f..2f7df01 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1931,6 +1931,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
ADD_TEST_MACRO(CMakeCommands.target_link_libraries target_link_libraries)
ADD_TEST_MACRO(CMakeCommands.target_include_directories target_include_directories)
+ ADD_TEST_MACRO(CMakeCommands.target_compile_definitions target_compile_definitions)
configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestCrash/test.cmake.in"