summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-06-27 12:43:06 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-06-27 12:43:06 (GMT)
commit07613ff7f8d20eee13d0a3e34574ab08c9f9bf21 (patch)
tree78a0addc1d036a510e9912821589c6f193861be9 /Tests/CMakeLists.txt
parent25e97d20ce632722d32f94f36be2ee6241e5cf92 (diff)
downloadCMake-07613ff7f8d20eee13d0a3e34574ab08c9f9bf21.zip
CMake-07613ff7f8d20eee13d0a3e34574ab08c9f9bf21.tar.gz
CMake-07613ff7f8d20eee13d0a3e34574ab08c9f9bf21.tar.bz2
COMP: fix tests where the building cmake doesn't have GET_TEST_PROPERTY
Alex
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 461e1b6..96ee5a9 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -621,7 +621,7 @@ IF(BUILD_TESTING)
--output-log "${CMake_BINARY_DIR}/Tests/CTestTest3/testOutput.log"
)
# these tests take a long time, make sure they have it
- IF(COMMAND SET_TESTS_PROPERTIES)
+ IF(COMMAND SET_TESTS_PROPERTIES AND COMMAND GET_TEST_PROPERTY)
# if timeouts have not already been set
GET_TEST_PROPERTY(CTestTest TIMEOUT PREVIOUS_TIMEOUT)
IF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
@@ -637,7 +637,7 @@ IF(BUILD_TESTING)
IF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
SET_TESTS_PROPERTIES ( CTestTest3 PROPERTIES TIMEOUT 1500)
ENDIF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
- ENDIF(COMMAND SET_TESTS_PROPERTIES)
+ ENDIF(COMMAND SET_TESTS_PROPERTIES AND COMMAND GET_TEST_PROPERTY)
ENDIF (CTEST_TEST_CTEST AND CMAKE_RUN_LONG_TESTS)
IF("${CMAKE_TEST_GENERATOR}" MATCHES Xcode)