summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-01-25 21:39:57 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-30 15:04:54 (GMT)
commit4befecc77caa97aeb450d9a2b6bcbe0985dc4054 (patch)
tree466fb00e26d9db362d64b530bc7bda952106e3d8 /Tests/CMakeLists.txt
parentbcd25808ac540d279a36a9e0f1b60f152fc0d6bb (diff)
downloadCMake-4befecc77caa97aeb450d9a2b6bcbe0985dc4054.zip
CMake-4befecc77caa97aeb450d9a2b6bcbe0985dc4054.tar.gz
CMake-4befecc77caa97aeb450d9a2b6bcbe0985dc4054.tar.bz2
ExternalData: Add tests covering interfaces and errors
Add a Module.ExternalData test to verify data retrieval and test argument DATA{} references. Add a RunCMake.ExternalData test to verify error handling and automatic transformation of a raw data to a content link and staged object.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 0c75892..c21922e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -312,6 +312,18 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(Module.CheckTypeSize CheckTypeSize)
+ add_test(Module.ExternalData ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Module/ExternalData"
+ "${CMake_BINARY_DIR}/Tests/Module/ExternalData"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-project ExternalDataTest
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --force-new-ctest-process
+ --test-command ${CMAKE_CTEST_COMMAND} -C \${CTEST_CONFIGURATION_TYPE} -V
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Module/ExternalData")
+
ADD_TEST_MACRO(Module.GenerateExportHeader GenerateExportHeader)
if (APPLE OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")