summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-09-10 20:17:39 (GMT)
committerDavid Cole <david.cole@kitware.com>2010-09-10 21:55:45 (GMT)
commit269a4b876a34483c5cb664499dc6b1634fa453ff (patch)
treef1af359bc63dc0a36e8e253aad441cb5d4736433 /Tests/CMakeLists.txt
parentde346204b823f79685fa6a0be5c3c376fdbb422b (diff)
downloadCMake-269a4b876a34483c5cb664499dc6b1634fa453ff.zip
CMake-269a4b876a34483c5cb664499dc6b1634fa453ff.tar.gz
CMake-269a4b876a34483c5cb664499dc6b1634fa453ff.tar.bz2
Enable calling commands with : in argv[1] (#9963)
The solution seems hackish, but it works: for NMake only, prepend a no-op command before each real command that begins with ". This is really a work-around for an NMake problem. When a command begins with ", nmake truncates the first argument to the command after the first : in that arg. It has a parsing problem. Workaround..., hackish..., but it should solve the issue for #9963 and its related friends. Also, modify the CustomCommand test to replicate the problem reported in issue #9963. Before the NMake specific code change, the test failed. Now, it passes. Ahhhhhh.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8e8d0ca..e4c979e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -376,7 +376,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--build-generator ${CMAKE_TEST_GENERATOR}
--build-project CustomCommand
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
- --build-exe-dir "${CMake_BINARY_DIR}/Tests/CustomCommand/bin"
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/CustomCommand/bin dir"
--test-command CustomCommand
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/CustomCommand")