summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-07-07 12:54:38 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-07-07 12:54:38 (GMT)
commit51fcb7b1b68c3094c181e0f7207f177a2ad1e7b4 (patch)
tree6ad75cfc7d1822fbdf969afe4074dadc745bb21c /Tests/CMakeLists.txt
parentf1626aa1013d0101333f05840263676cb0a7b9cd (diff)
parent92af3664c922b4b3127700c426a01ab5fec097b8 (diff)
downloadCMake-51fcb7b1b68c3094c181e0f7207f177a2ad1e7b4.zip
CMake-51fcb7b1b68c3094c181e0f7207f177a2ad1e7b4.tar.gz
CMake-51fcb7b1b68c3094c181e0f7207f177a2ad1e7b4.tar.bz2
Merge topic 'ExternalProject_test'
92af3664 Tests: split the ExternalProject test
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index cb455e0..dc4f894 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1249,6 +1249,21 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
set_tests_properties(ExternalProject PROPERTIES
TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
+ add_test(ExternalProjectLocal ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/ExternalProjectLocal"
+ "${CMake_BINARY_DIR}/Tests/ExternalProjectLocal"
+ ${build_generator_args}
+ --build-project ExternalProjectLocalTest
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/ExternalProjectLocal"
+ --force-new-ctest-process
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/ExternalProjectLocal")
+ set_tests_properties(ExternalProjectLocal PROPERTIES
+ TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
+
add_test(ExternalProjectUpdateSetup ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/ExternalProjectUpdate"