summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Farrier <john.farrier@digitalinblue.com>2013-04-29 14:48:22 (GMT)
committerBrad King <brad.king@kitware.com>2013-05-16 17:06:44 (GMT)
commit79ec7868d0f08c9ff2e6fa6454b205132acecc24 (patch)
treea5526400e3ac907c10b42cfd28fbcd419a11a020 /Tests/CMakeLists.txt
parentc80594ba1274c3dc44c3f2efd70bd5c3d9066bf5 (diff)
downloadCMake-79ec7868d0f08c9ff2e6fa6454b205132acecc24.zip
CMake-79ec7868d0f08c9ff2e6fa6454b205132acecc24.tar.gz
CMake-79ec7868d0f08c9ff2e6fa6454b205132acecc24.tar.bz2
VS: Add Windows Forms Support
Add support to maintain designer functionality for Visual Studio C++ Windows Forms projects. Also add a test project showing how to use the CMakeLists.txt file and, when successfully configured, will allow use of the designer for the included form.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index e07bb69..21c9490 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1448,6 +1448,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
ADD_TEST_MACRO(SBCS SBCS)
endif()
+ if(NOT "${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [6789]( |$)"
+ AND NOT CMAKE_TEST_GENERATOR_TOOLSET)
+ ADD_TEST_MACRO(VSWindowsFormsResx VSWindowsFormsResx)
+ endif()
+
add_test(VSExternalInclude ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/VSExternalInclude"