summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDomen Vrankar <domen.vrankar@gmail.com>2015-03-29 18:55:20 (GMT)
committerBrad King <brad.king@kitware.com>2015-03-31 18:04:13 (GMT)
commit681f3a2f012dcd17f63faa3c6f932ae92278e3bd (patch)
treeb0e0c871e1c5813b89f0ef5479991a64d1907150 /Tests/CMakeLists.txt
parentc1f8c6cdf94d650df1bd8ec847ae7ac453550978 (diff)
downloadCMake-681f3a2f012dcd17f63faa3c6f932ae92278e3bd.zip
CMake-681f3a2f012dcd17f63faa3c6f932ae92278e3bd.tar.gz
CMake-681f3a2f012dcd17f63faa3c6f932ae92278e3bd.tar.bz2
CPackRPM: Add basic symlink support (#15209)
RPM packages can contain symbolic links to relative paths - including support for multiple relocation paths through generation of post install relocation scripts. Add basic support with limitations described in documentation.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index f2df4af..5944d08 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -991,6 +991,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
${build_generator_args}
--build-project CPackComponentsForAll
--build-options ${build_options}
+ -DCPACK_GENERATOR:STRING=${CPackGen}
-DCPACK_BINARY_${CPackGen}:BOOL=ON
${CPackRun_CPackComponentWay}
${CPackComponentsForAll_BUILD_OPTIONS}