summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-04-17 15:01:03 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-04-17 15:01:37 (GMT)
commit2ed688a863671d58513055ad56ab04d6be05295b (patch)
tree91c01b78176bf39f6058fe3b9c1676dbb57cbcad /Tests/CMakeLists.txt
parent5cd187147ecbd29a0afc5a6b49f2232b61a1ab8c (diff)
parentfb3370b6a1681190ffd8daf63975c44ce8fc1c49 (diff)
downloadCMake-2ed688a863671d58513055ad56ab04d6be05295b.zip
CMake-2ed688a863671d58513055ad56ab04d6be05295b.tar.gz
CMake-2ed688a863671d58513055ad56ab04d6be05295b.tar.bz2
Merge topic 'msvc-runtime-library'
fb3370b6a1 MSVC: Add abstraction for runtime library selection f621e7fa5d VS: Fix Fortran runtime library flag map special case for '-' options Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: Ben Boeckel <ben.boeckel@kitware.com> Acked-by: Leonid Pospelov <pospelovlm@yandex.ru> Merge-request: !3211
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2e0902c..bc4812b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1995,6 +1995,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
ADD_TEST_MACRO(PrecompiledHeader foo)
endif()
+ ADD_TEST_MACRO(MSVCRuntimeLibrary)
+ if(CMAKE_Fortran_COMPILER)
+ ADD_TEST_MACRO(MSVCRuntimeLibrary.Fortran)
+ endif()
endif()
if(MSVC OR
"${CMAKE_GENERATOR}" MATCHES "(MSYS|MinGW) Makefiles")