summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-24 11:38:24 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-12-24 11:38:24 (GMT)
commit661622f011810093433afa5c9a4795b3d2f19070 (patch)
tree0f5bf633e9eacfde5787cbf881921b16faf1b841 /Tests/CMakeLists.txt
parentc20d3d319cb97da5793beebe42a80361b2d247c4 (diff)
parent07fc7b75ef981300e7d873091ee90083b18d1c4a (diff)
downloadCMake-661622f011810093433afa5c9a4795b3d2f19070.zip
CMake-661622f011810093433afa5c9a4795b3d2f19070.tar.gz
CMake-661622f011810093433afa5c9a4795b3d2f19070.tar.bz2
Merge topic 'ninja-fix-subdir-objlib-languages'
07fc7b75 Tests: Test using objects from a language enabled in a subdirectory (#15325) fdbfcfdf Ninja: Generate rules only for languages compiled in a target (#15325)
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8df27f4..dea30e4 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -251,6 +251,7 @@ if(BUILD_TESTING)
endif()
ADD_TEST_MACRO(COnly COnly)
ADD_TEST_MACRO(CxxOnly CxxOnly)
+ ADD_TEST_MACRO(CxxSubdirC CxxSubdirC)
ADD_TEST_MACRO(IPO COnly/COnly)
ADD_TEST_MACRO(OutDir runtime/OutDir)
ADD_TEST_MACRO(ObjectLibrary UseCshared)