summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-31 13:19:31 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2016-08-31 13:19:31 (GMT)
commit6f8b93983a3bfb4a9262cae8e9b989edb61e8a4b (patch)
treea430cba0fcb321a72db0a5f5414f36ddf0268585 /Tests/CMakeLists.txt
parent59d559af2e35d3521c7cffc4a0c7c33ffaf2c744 (diff)
parent39ac889d636ee8ce083e00ab2c8351c6148150ef (diff)
downloadCMake-6f8b93983a3bfb4a9262cae8e9b989edb61e8a4b.zip
CMake-6f8b93983a3bfb4a9262cae8e9b989edb61e8a4b.tar.gz
CMake-6f8b93983a3bfb4a9262cae8e9b989edb61e8a4b.tar.bz2
Merge topic 'import-libuv'
39ac889d cmake: Add trivial usage of libuv 7cf369fe Do not build libuv on HP-UX 075cae51 Do not build libuv on SPARC 9a53af40 Do not build libuv on Cygwin 219f7411 Do not build libuv on Mac OS X 10.4 and lower 8a5beef3 Add option to build CMake against a system libuv e56aa462 FindLibUV: Add module to find libuv package 551d5aed libuv: Fix unused variable warning in uv_loop_close f4f8074b libuv: Avoid including macOS CoreServices header globally a63aaaed libuv: Always include our own header first 9130b53a libuv: Conditionally declare Windows APIs for VS 2008 and below b52afa46 libuv: Fix anonymous union syntax 05dbc204 libuv: Fix Windows API function typedef syntax 75139374 libuv: Install LICENSE file with CMake documentation 95dcc4e4 libuv: Disable warnings to avoid changing 3rd party code 13b7e758 libuv: Build the library within CMake ...
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 4e9b062..3d0f264 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1373,6 +1373,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
add_subdirectory(FindJsonCpp)
endif()
+ if(CMake_TEST_FindLibUV)
+ add_subdirectory(FindLibUV)
+ endif()
+
if(CMake_TEST_FindLTTngUST)
add_subdirectory(FindLTTngUST)
endif()