summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-01-25 13:33:23 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-01-25 13:33:35 (GMT)
commit76f5a87cf1b653e254d26aff0f7fcf2115fb5e24 (patch)
treef00f75101a108b3b5394670b66435aef46f0b13a /Tests/CMakeLists.txt
parent03050c5689f5b6bd91b378316a919018629133fc (diff)
parent044831117955dfa33ed4e0c7799ea3f37258b149 (diff)
downloadCMake-76f5a87cf1b653e254d26aff0f7fcf2115fb5e24.zip
CMake-76f5a87cf1b653e254d26aff0f7fcf2115fb5e24.tar.gz
CMake-76f5a87cf1b653e254d26aff0f7fcf2115fb5e24.tar.bz2
Merge topic 'sourceFile-new-properties'
04483111 sourceFile properties: add property INCLUDE_DIRECTORIES 3073bd1f VisualStudio generators: refactoring 78b1c2e0 sourceFile properties: add property COMPILE_OPTIONS 3f935e69 LocalGenerator: refactoring Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1596
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 506e995..cbfbd91 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -390,6 +390,9 @@ if(BUILD_TESTING)
endif()
ADD_TEST_MACRO(SourcesProperty SourcesProperty)
ADD_TEST_MACRO(SourceFileProperty SourceFileProperty)
+ if (NOT CMAKE_GENERATOR STREQUAL "Xcode")
+ ADD_TEST_MACRO(SourceFileIncludeDirProperty SourceFileIncludeDirProperty)
+ endif()
if(CMAKE_CXX_COMPILER_ID STREQUAL GNU
AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.7)
set(runCxxDialectTest 1)