summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-04-19 14:42:33 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-04-19 14:46:10 (GMT)
commita7e0453a3238cbd617cf2fff7388fd3d879dfd65 (patch)
treec5c878f9b65a261c935ad37cd934640eb407a4e6 /Tests/CMakeLists.txt
parent334efdebb8c69e6327fecb42ed1ae3cfcdb1cad6 (diff)
parent9e338b57b7a7094b150e10512e6fd758e19eac8c (diff)
downloadCMake-a7e0453a3238cbd617cf2fff7388fd3d879dfd65.zip
CMake-a7e0453a3238cbd617cf2fff7388fd3d879dfd65.tar.gz
CMake-a7e0453a3238cbd617cf2fff7388fd3d879dfd65.tar.bz2
Merge topic 'fix-CMakeTestAllGenerators'
9e338b57 Tests: Drop machine-specific logic from CMakeTestAllGenerators 2790ffc9 Tests: Run CMakeTestAllGenerators serially f1e51ec3 Tests: Fix CMakeTestAllGenerators generator list Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !720
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 491d974..e270748 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1158,6 +1158,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
)
list(APPEND TEST_BUILD_DIRS
"${CMake_BINARY_DIR}/Tests/CMakeTestAllGenerators")
+ # This test runs a lot of processes. Do not make them compete
+ # for resources with other tests.
+ set_property(TEST CMakeTestAllGenerators PROPERTY RUN_SERIAL 1)
endif()
if(NOT DEFINED CTEST_RUN_CMakeTestMultipleConfigures)