summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-04-06 12:58:21 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-04-06 12:58:21 (GMT)
commitdfbde6fa991e60853a9f7ad165c4b8c8416a9ba4 (patch)
treed870b221de8bba67d7342ce4287349f4feb7bcf1 /Tests/CMakeLists.txt
parent89ee57f6c79858bf350a5afce2ef588348dacb1c (diff)
parent9a544f2d987df940625465129a5f00bea01ad4eb (diff)
downloadCMake-dfbde6fa991e60853a9f7ad165c4b8c8416a9ba4.zip
CMake-dfbde6fa991e60853a9f7ad165c4b8c8416a9ba4.tar.gz
CMake-dfbde6fa991e60853a9f7ad165c4b8c8416a9ba4.tar.bz2
Merge topic 'gcov-module-coverage-exclude'
9a544f2d CTestCoverageCollectGCOV: Support CTEST_CUSTOM_COVERAGE_EXCLUDE
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 1df39aa..f80191b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2356,12 +2356,13 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
"${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake"
@ONLY ESCAPE_QUOTES)
add_test(CTestCoverageCollectGCOV ${CMAKE_CTEST_COMMAND}
+ -C \${CTEST_CONFIGURATION_TYPE}
-S "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake" -VV
--output-log "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/testOut.log"
)
set_tests_properties(CTestCoverageCollectGCOV PROPERTIES
PASS_REGULAR_EXPRESSION
- "PASSED with correct output.*Testing/CoverageInfo/echoargs.gcov")
+ "PASSED with correct output.*Testing/CoverageInfo/main.cpp.gcov")
configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestEmptyBinaryDirectory/test.cmake.in"