summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-06-28 13:06:34 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2016-06-28 13:06:34 (GMT)
commit1b021a64f8bf4d9544acb18628e3821f61f49e10 (patch)
treea6a50b9f9614b5f2c93c5e14ef8059a3539cd1ac /Tests/CMakeLists.txt
parent7287893d411dde3b9afc6a4c8896dd9d15db9e04 (diff)
parent15b3f6f0f187ab12c29e437f737356bed13d977b (diff)
downloadCMake-1b021a64f8bf4d9544acb18628e3821f61f49e10.zip
CMake-1b021a64f8bf4d9544acb18628e3821f61f49e10.tar.gz
CMake-1b021a64f8bf4d9544acb18628e3821f61f49e10.tar.bz2
Merge topic 'ninja-no-rsp-for-rc'
15b3f6f0 ninja, rc: ignore CMAKE_NINJA_FORCE_RESPONSE_FILE for RC files
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 5911682..b3d61bd 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -274,6 +274,9 @@ if(BUILD_TESTING)
endif()
if(TEST_RESOURCES)
ADD_TEST_MACRO(VSResource VSResource)
+ if (CMAKE_GENERATOR MATCHES "Ninja")
+ add_test_macro(VSResourceNinjaForceRSP VSResourceNinjaForceRSP)
+ endif ()
endif()
ADD_TEST_MACRO(MSManifest MSManifest)
ADD_TEST_MACRO(Simple Simple)