summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-06-26 11:41:21 (GMT)
committerBrad King <brad.king@kitware.com>2019-06-26 12:36:48 (GMT)
commit8fbd25772f7db4c6f152a28b0050e6b263951049 (patch)
tree68e34a9a455b5236bca8e3af165482f2039fa5fa /Tests/CMakeLists.txt
parent07807a20060b4e9561239d8b26ebbb4f38b7c7f3 (diff)
downloadCMake-8fbd25772f7db4c6f152a28b0050e6b263951049.zip
CMake-8fbd25772f7db4c6f152a28b0050e6b263951049.tar.gz
CMake-8fbd25772f7db4c6f152a28b0050e6b263951049.tar.bz2
CUDA: Implement MSVC runtime library abstraction
In commit fb3370b6a1 (MSVC: Add abstraction for runtime library selection, 2019-04-10, v3.15.0-rc1~229^2) we overlooked updating flags for CUDA on Windows, where nvcc uses MSVC as the host compiler. Add them now and update the MSVCRuntimeLibrary test to cover CUDA. Fixes: #19428
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 920af04..e73b277 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2001,6 +2001,7 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
ADD_TEST_MACRO(PrecompiledHeader foo)
endif()
+ set(MSVCRuntimeLibrary_BUILD_OPTIONS -DCMake_TEST_CUDA=${CMake_TEST_CUDA})
ADD_TEST_MACRO(MSVCRuntimeLibrary)
if(CMAKE_Fortran_COMPILER)
ADD_TEST_MACRO(MSVCRuntimeLibrary.Fortran)