summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-04-22 13:15:46 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-04-22 13:15:59 (GMT)
commitd9eb9e785e9873a7b034aec667bd808d34f1a907 (patch)
tree314c0c03cdda2504589db9535813086a72f20817 /Tests/CMakeLists.txt
parentf9fbc78cd638c1bb874ffd24531f98c095ca1377 (diff)
parent7ca13e04fa9301325d7d0f7cd664829e65f2b4c1 (diff)
downloadCMake-d9eb9e785e9873a7b034aec667bd808d34f1a907.zip
CMake-d9eb9e785e9873a7b034aec667bd808d34f1a907.tar.gz
CMake-d9eb9e785e9873a7b034aec667bd808d34f1a907.tar.bz2
Merge topic 'win-user-manifest-rc'
7ca13e04fa Windows: Merge user-provided manifests into compiled resource Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4484
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index cc2931b..cf8aa14 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -363,7 +363,10 @@ if(BUILD_TESTING)
add_test_macro(VSResourceNinjaForceRSP VSResourceNinjaForceRSP)
endif ()
endif()
- ADD_TEST_MACRO(MSManifest MSManifest)
+ if(_isMultiConfig)
+ set(MSManifest_CTEST_OPTIONS -C $<CONFIGURATION>)
+ endif()
+ ADD_TEST_MACRO(MSManifest ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>)
ADD_TEST_MACRO(Simple Simple)
ADD_TEST_MACRO(PreOrder PreOrder)
ADD_TEST_MACRO(MissingSourceFile MissingSourceFile)