summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-11-15 14:03:38 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-11-15 14:04:40 (GMT)
commitee200b7d96d3256c744077ef3aae9f2de8621974 (patch)
tree8ec5f5cf18c1d0ab5432c6532f2853a3ce44fcd8 /Tests/CMakeLists.txt
parent18bacbd94814b7a0750b162161e803410a5cb1bb (diff)
parentd2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4 (diff)
downloadCMake-ee200b7d96d3256c744077ef3aae9f2de8621974.zip
CMake-ee200b7d96d3256c744077ef3aae9f2de8621974.tar.gz
CMake-ee200b7d96d3256c744077ef3aae9f2de8621974.tar.bz2
Merge topic 'objc-tests'
d2e5e6ff1a Tests: Organize Objective C/C++ test directories Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4051
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt88
1 files changed, 2 insertions, 86 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 185401f..b45782e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2331,92 +2331,8 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
-P ${CMake_SOURCE_DIR}/Tests/CFBundleTest/VerifyResult.cmake)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/CFBundleTest")
- ADD_TEST_MACRO(ObjC++ ObjC++)
-
- add_test(Objective-C.simple-build-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/simple-build-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/simple-build-test"
- --build-two-config
- ${build_generator_args}
- --build-project simple-build-test
- --build-options ${build_options}
- --test-command simple-build-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/simple-build-test")
-
- add_test(Objective-C.c-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/c-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/c-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project c-file-extension-test
- --build-options ${build_options}
- --test-command c-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/c-file-extension-test")
-
- add_test(Objective-C.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/cxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project cxx-file-extension-test
- --build-options ${build_options}
- --test-command cxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test")
-
- add_test(Objective-C.objc-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C/objc-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project objc-file-extension-test
- --build-options ${build_options}
- --test-command objc-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test")
-
- add_test(Objective-CXX.simple-build-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/simple-build-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test"
- --build-two-config
- ${build_generator_args}
- --build-project simple-build-test
- --build-options ${build_options}
- --test-command simple-build-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test")
-
- add_test(Objective-CXX.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/cxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project cxx-file-extension-test
- --build-options ${build_options}
- --test-command cxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test")
-
- add_test(Objective-CXX.objcxx-file-extension-test ${CMAKE_CTEST_COMMAND}
- --build-and-test
- "${CMake_SOURCE_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
- "${CMake_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
- --build-two-config
- ${build_generator_args}
- --build-project objcxx-file-extension-test
- --build-options ${build_options}
- --test-command objcxx-file-extension-test
- )
- list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test")
-
+ add_subdirectory(ObjC)
+ add_subdirectory(ObjCXX)
endif ()
endif ()