summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-03-08 20:14:03 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-03-08 20:14:03 (GMT)
commitf55119e63b4063daf6c8cdce5eb5415d04b0c2bd (patch)
tree5afda3c63fb305d3c646c7046f1ea2694afd9411 /Tests/CMakeLists.txt
parent9f6c38253a29288a7f8479d43e7c87fd3d958e79 (diff)
parentb28e7fa174798717ebf8e18b8d97755d3568b04d (diff)
downloadCMake-f55119e63b4063daf6c8cdce5eb5415d04b0c2bd.zip
CMake-f55119e63b4063daf6c8cdce5eb5415d04b0c2bd.tar.gz
CMake-f55119e63b4063daf6c8cdce5eb5415d04b0c2bd.tar.bz2
Merge topic 'fix-12189-support-SBCS-in-VS'
b28e7fa VS6: Avoid SBCS test on VS6 (#12189) df19b9c VS6: Avoid _MBCS define when _SBCS is defined (#12189) ba89e92 Visual Studio: Allow setting Single Byte Character Set (#12189)
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 53c59cc..07a6c36 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1338,6 +1338,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
endif()
IF(${CMAKE_TEST_GENERATOR} MATCHES "Visual Studio")
+ IF(NOT MSVC60)
+ ADD_TEST_MACRO(SBCS SBCS)
+ ENDIF(NOT MSVC60)
+
ADD_TEST(VSExternalInclude ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/VSExternalInclude"