summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2011-07-13 00:13:33 (GMT)
committerStephen Kelly <steveire@gmail.com>2011-08-07 16:33:47 (GMT)
commit30880707c094ac5c0edd85d0857afb6fbae55326 (patch)
tree837b58ac331f34eeefaced63c4c0a71ee59ef69e /Tests/CMakeLists.txt
parent955d5133ab2f8bca5372e81af544cafdafc31994 (diff)
downloadCMake-30880707c094ac5c0edd85d0857afb6fbae55326.zip
CMake-30880707c094ac5c0edd85d0857afb6fbae55326.tar.gz
CMake-30880707c094ac5c0edd85d0857afb6fbae55326.tar.bz2
Add the GenerateExportMacro with unit tests.
Reviewed-by: Marcus D. Hanwell <marcus.hanwell@kitware.com>
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 4bf83b7..eececb0 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -221,6 +221,8 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(Module.CheckTypeSize CheckTypeSize)
+ ADD_TEST_MACRO(Module.GenerateExportHeader GenerateExportHeader)
+
ADD_TEST(LinkFlags-prepare
${CMAKE_CTEST_COMMAND} -C \${CTEST_CONFIGURATION_TYPE}
--build-and-test