summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2019-05-11 10:55:58 (GMT)
committerSebastian Holtermann <sebholt@xwmw.org>2019-05-14 15:50:14 (GMT)
commitc11f089d7381747d9e2eac88c00621e2ec32e4b7 (patch)
tree7c83fae23523575756a87a6fc6118a4c4e704025 /Tests/CMakeLists.txt
parent012d599e26392312266e96d5ff6d0b905e7e2647 (diff)
downloadCMake-c11f089d7381747d9e2eac88c00621e2ec32e4b7.zip
CMake-c11f089d7381747d9e2eac88c00621e2ec32e4b7.tar.gz
CMake-c11f089d7381747d9e2eac88c00621e2ec32e4b7.tar.bz2
Tests: Extend MakeClean test to cover ADDITIONAL_CLEAN_FILES
This extends the MakeClean test to cover the - ADDITIONAL_CLEAN_FILES directory property and the - ADDITIONAL_CLEAN_FILES target property as well.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index bc4812b..d992986 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2007,7 +2007,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
ADD_TEST_MACRO(CheckCompilerRelatedVariables CheckCompilerRelatedVariables)
- if("${CMAKE_GENERATOR}" MATCHES "Makefile")
+ if("${CMAKE_GENERATOR}" MATCHES "Makefile" OR
+ "${CMAKE_GENERATOR}" MATCHES "Ninja")
add_test(MakeClean ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/MakeClean"