summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2011-03-28 15:11:27 (GMT)
committerBrad King <brad.king@kitware.com>2011-03-31 17:33:10 (GMT)
commit2973c1fbebcbaff944ff2d75e5a44437bf9725c7 (patch)
tree5da5072ce3961e4ae4c0f824bdb929cac0b9d6fd /Tests/CMakeLists.txt
parent64a5e209998f12662a56346f855b1973cbbd0440 (diff)
downloadCMake-2973c1fbebcbaff944ff2d75e5a44437bf9725c7.zip
CMake-2973c1fbebcbaff944ff2d75e5a44437bf9725c7.tar.gz
CMake-2973c1fbebcbaff944ff2d75e5a44437bf9725c7.tar.bz2
Add component support to DragNDrop generator.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 6265f81..08d15d5 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -566,6 +566,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
set(CPackRun_CPackCommand "-DCPackCommand=${CMAKE_CPACK_COMMAND}")
# set up list of CPack generators
list(APPEND GENLST "ZIP")
+ if(APPLE)
+ list(APPEND GENLST "DragNDrop")
+ endif(APPLE)
if (CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT CMAKE_CURRENT_BINARY_DIR MATCHES ".* .*")
find_program(RPMBUILD NAMES rpmbuild)
endif(CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT CMAKE_CURRENT_BINARY_DIR MATCHES ".* .*")