summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-08-20 13:16:35 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-08-20 13:19:22 (GMT)
commitb80417f0fd1491d1c0f5d57019b47d4c13729545 (patch)
treee55ae56966bd154cec46c56184a9f4a6f1b09d7e /Tests/CMakeLists.txt
parent8c1d3e3b79fb921bfada3b19e6bb4115da4a4e6e (diff)
parent6f6a32a0f601688da24e1737509a0b6e1ed4f63f (diff)
downloadCMake-b80417f0fd1491d1c0f5d57019b47d4c13729545.zip
CMake-b80417f0fd1491d1c0f5d57019b47d4c13729545.tar.gz
CMake-b80417f0fd1491d1c0f5d57019b47d4c13729545.tar.bz2
Merge topic 'cmake-tutorial'
6f6a32a0f6 Tutorial: Improve Step 9 6a35d630dc Tutorial: Improve Step 8 61d4d990d6 Tutorial: Improve Step 7 a36731c634 Tutorial: Improve Step 6 df9cdf629c Tutorial: Improve Step 5 442c0f0d46 Tutorial: Improve Step 4 bc64401c3d Tutorial: Improve Step 3 49ce4d6ff4 Tutorial: Improve Step 2 ... Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3528
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index febcd7a..34858b8 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1598,7 +1598,7 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
endfunction()
if(NOT CMake_TEST_EXTERNAL_CMAKE)
- foreach(STP RANGE 1 11)
+ foreach(STP RANGE 2 11)
add_tutorial_test(Step${STP} TRUE)
endforeach()
add_tutorial_test(Complete TRUE)
@@ -2130,8 +2130,8 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
macro(add_test_VSWinCE name generator systemName systemVersion generatorPlatform)
# TODO: Fix the tutorial to make it work in cross compile
# currently the MakeTable is build for target and can not be used on the host
- # This happens in part 5 so we build only part 1-4 of the tutorial
- foreach(STP RANGE 1 4)
+ # This happens in part 5 so we build only through part 4 of the tutorial.
+ foreach(STP RANGE 2 4)
add_test(NAME "TutorialStep${STP}.${name}" COMMAND ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Help/guide/tutorial/Step${STP}"