summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-02-22 13:44:13 (GMT)
committerBrad King <brad.king@kitware.com>2013-02-22 13:57:11 (GMT)
commitf17711c546304a5e62a06796e0124c64284bfb9a (patch)
treefa85552aed2781104152fbae7ee146801b7542f5 /Tests/CMakeLists.txt
parentc1f5780e2d25015ba22dd0a7c8d43c925a62a7f6 (diff)
downloadCMake-f17711c546304a5e62a06796e0124c64284bfb9a.zip
CMake-f17711c546304a5e62a06796e0124c64284bfb9a.tar.gz
CMake-f17711c546304a5e62a06796e0124c64284bfb9a.tar.bz2
FPHSA: Convert FOUND_VAR failure test to RunCMake
Move the Tests/FPHSA_InvalidFOUND_VAR test case over to a new RunCMake.FPHSA test with a BadFoundVar case. The RunCMake tests are built to cover failure cases easily and robustly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2725202..f8e4afd 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -147,9 +147,6 @@ if(BUILD_TESTING)
# add a bunch of standard build-and-test style tests
ADD_TEST_MACRO(CommandLineTest CommandLineTest)
ADD_TEST_MACRO(FindPackageTest FindPackageTest)
- ADD_TEST_MACRO(FPHSA_InvalidFOUND_VAR FPHSA_InvalidFOUND_VAR)
- set_tests_properties(FPHSA_InvalidFOUND_VAR PROPERTIES
- PASS_REGULAR_EXPRESSION "The argument for FOUND_VAR is .badfoundvar_FOUND., but only")
ADD_TEST_MACRO(FindModulesExecuteAll FindModulesExecuteAll)
ADD_TEST_MACRO(StringFileTest StringFileTest)
ADD_TEST_MACRO(TryCompile TryCompile)