summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-02-06 14:12:24 (GMT)
committerBrad King <brad.king@kitware.com>2019-02-06 15:17:02 (GMT)
commit562ea5d0e200a5e005ef33dca45a7d08a5e8fbb7 (patch)
treef3c5b37c1b9e24878146392e4963240d841e815c /Tests/CMakeLists.txt
parent062cfd991faac000d484c74e5af7d65726c655dc (diff)
downloadCMake-562ea5d0e200a5e005ef33dca45a7d08a5e8fbb7.zip
CMake-562ea5d0e200a5e005ef33dca45a7d08a5e8fbb7.tar.gz
CMake-562ea5d0e200a5e005ef33dca45a7d08a5e8fbb7.tar.bz2
Tests: Add a way to configure custom options for FortranModules test
Read an undocumented cache entry to allow some CI builds to configure this test in a special way.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ed98d97..86ad72c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3373,6 +3373,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
--build-options ${build_options}
-DCMake_TEST_NESTED_MAKE_PROGRAM:FILEPATH=${CMake_TEST_EXPLICIT_MAKE_PROGRAM}
-DCMake_TEST_Fortran_SUBMODULES:BOOL=${CMake_TEST_Fortran_SUBMODULES}
+ ${CMake_TEST_FortranModules_BUILD_OPTIONS}
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/FortranModules")
endif()