summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2007-10-01 19:57:34 (GMT)
committerDavid Cole <david.cole@kitware.com>2007-10-01 19:57:34 (GMT)
commit890efa79807df367f506a3d35fe9a6b323133b2d (patch)
treedde7ab0d8130e1098c06d279297ad872c8ad10d6 /Tests/CMakeLists.txt
parente6d45a2cf5f7055fcccb0a6679c586fd2791e243 (diff)
downloadCMake-890efa79807df367f506a3d35fe9a6b323133b2d.zip
CMake-890efa79807df367f506a3d35fe9a6b323133b2d.tar.gz
CMake-890efa79807df367f506a3d35fe9a6b323133b2d.tar.bz2
COMP: Rename the executables for the SimpleInstall tests so that the executable files that run during the test do not have the word install in their file names. This allows running the tests on Windows Vista without admin privileges and without adding a manifest containing the asInvoker requestedExecutionLevel element.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8b34f4d..930ac25 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -182,7 +182,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
--build-two-config
--build-options
"-DCMAKE_INSTALL_PREFIX:PATH=${SimpleInstallInstallDir}"
- --test-command ${SimpleInstallInstallDir}/MyTest/bin/SimpleInstallExe)
+ --test-command ${SimpleInstallInstallDir}/MyTest/bin/SimpleInstExe)
ADD_TEST(SimpleInstall-Stage2 ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/SimpleInstallS2"
@@ -194,7 +194,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
--build-options
"-DCMAKE_INSTALL_PREFIX:PATH=${SimpleInstallInstallDir}"
"-DSTAGE2:BOOL=1"
- --test-command ${SimpleInstallInstallDir}/MyTest/bin/SimpleInstallS2)
+ --test-command ${SimpleInstallInstallDir}/MyTest/bin/SimpleInstExeS2)
ADD_TEST(X11 ${CMAKE_CTEST_COMMAND}
--build-and-test