summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-12-28 20:25:49 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2010-12-28 20:25:49 (GMT)
commit97c5171d6c1eb0b201662067e9c041003415ae93 (patch)
tree19ef7903aafb37f634f1dbf740d633e1355a3e00 /Tests/CMakeLists.txt
parent8b73f54bc63f50c48d9356c108eec44bb5e0dbc3 (diff)
parent667a90a0844a2b00a046e9597811c06905b6347d (diff)
downloadCMake-97c5171d6c1eb0b201662067e9c041003415ae93.zip
CMake-97c5171d6c1eb0b201662067e9c041003415ae93.tar.gz
CMake-97c5171d6c1eb0b201662067e9c041003415ae93.tar.bz2
Merge topic 'dev/add_test-working-directory'
667a90a Fix sentence break in add_test documentation 96309fc Make TestsWorkingDirectory test a C file a4a5e37 Use iostream to make Borland happy cfe53cd Fully specify the path to old-signature add_test 017d4e9 Group adding tests with its properties 561cc33 Only test the default cwd with Makefiles d87bae7 Simplify the _default_cwd derivation 992c74f Use --><-- markers to denote the path 5249551 Flip slashes around on Windows 0a014da Add ctype.h include for toupper() af12f83 Fix header includes for C++ and Visual Studio 5597aa2 Rename the project to match the test 9bf4165 Add tests for WORKING_DIRECTORY arg to add_test 42de5d0 Add WORKING_DIRECTORY argument to add_test 7679f9f Rename WorkingDirectory test d95f817 Add the WORKING_DIRECTORY property to tests
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7409b0b..289e632 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1114,6 +1114,19 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleGeneratorTest")
ENDIF(APPLE AND CTEST_TEST_CPACK)
+ ADD_TEST(TestsWorkingDirectory ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/TestsWorkingDirectory"
+ "${CMake_BINARY_DIR}/Tests/TestsWorkingDirectory"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-project TestsWorkingDirectoryProj
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/TestsWorkingDirectory"
+ --force-new-ctest-process
+ --test-command ${CMAKE_CTEST_COMMAND} -V
+ )
+ LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/TestsWorkingDirectory")
+
# Make sure CTest can handle a test with no newline in output.
ADD_TEST(CTest.NoNewline
${CMAKE_CMAKE_COMMAND} -E echo_append "This line has no newline!")