summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-10-02 18:31:05 (GMT)
committerBrad King <brad.king@kitware.com>2019-10-04 14:39:00 (GMT)
commit9c9e66289acc7f54dfdb518a92b625f5a34c7c2d (patch)
tree9d378288d391e394c059e8acd1e8a4a263b5bb93 /Tests/CMakeLists.txt
parent395e5f77fcd900b4a7a48eaa2da2e3554b694cf1 (diff)
downloadCMake-9c9e66289acc7f54dfdb518a92b625f5a34c7c2d.zip
CMake-9c9e66289acc7f54dfdb518a92b625f5a34c7c2d.tar.gz
CMake-9c9e66289acc7f54dfdb518a92b625f5a34c7c2d.tar.bz2
Tests: Enable ConfigSources test on every configuration
Revise the test itself to work in all configurations and verify that certain sources are only built by whatever configuration is tested.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ed20b91..32b580b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -451,8 +451,8 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(StagingPrefix StagingPrefix)
ADD_TEST_MACRO(ImportedSameName ImportedSameName)
ADD_TEST_MACRO(InterfaceLibrary InterfaceLibrary)
- if (CMAKE_BUILD_TYPE MATCHES "[Dd][Ee][Bb][Uu][Gg]")
- set(ConfigSources_BUILD_OPTIONS -DCMAKE_BUILD_TYPE=Debug)
+ if(NOT _isMultiConfig)
+ set(ConfigSources_BUILD_OPTIONS -DCMAKE_BUILD_TYPE=$<CONFIGURATION>)
ADD_TEST_MACRO(ConfigSources ConfigSources)
endif()
ADD_TEST_MACRO(SourcesProperty SourcesProperty)