summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-06-20 13:42:16 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-06-20 13:42:25 (GMT)
commite11f660ae1b31f730212af43e1094f8dc3d42ef8 (patch)
treec2640181f8d0361b6682fb004d5fa6b8d4d8ac19 /Tests/CMakeLists.txt
parent20f042374730b2e1ee756c3b5939b63d6769cac3 (diff)
parentca6920689300249f67c4914cef521963c72a0d3f (diff)
downloadCMake-e11f660ae1b31f730212af43e1094f8dc3d42ef8.zip
CMake-e11f660ae1b31f730212af43e1094f8dc3d42ef8.tar.gz
CMake-e11f660ae1b31f730212af43e1094f8dc3d42ef8.tar.bz2
Merge topic 'xcode-10-legacy-build-system'
ca69206893 Tests: Do not use i386 architecture with Xcode 10 and above 71fa78ff7a Tests: Teach RunCMake to ignore Xcode missing file type warnings 057ecb8f6f C++ feature checks: Ignore Xcode warnings 985d3a162c Xcode: Use legacy build system Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2151
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9aed3ba..89babe4 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -252,6 +252,10 @@ if(BUILD_TESTING)
set(CMake_TEST_XCODE_VERSION "${CMAKE_MATCH_1}")
endif()
endif()
+ if(NOT CMake_TEST_XCODE_VERSION VERSION_LESS 10)
+ # Since Xcode 10 we do not have two supported architectures for the host.
+ set(CTEST_TEST_OSX_ARCH 0)
+ endif()
if(CMAKE_OSX_SYSROOT)
execute_process(
COMMAND xcodebuild -sdk ${CMAKE_OSX_SYSROOT} -version ProductName