summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-08-20 19:39:26 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-08-20 19:39:26 (GMT)
commit14c8096ba88502409f076cf0b0e5fe471c18f11b (patch)
tree0a719a005cb00dc8f260144f507181aba03d6329 /Tests/CMakeLists.txt
parentd4be75be128906ea829fd0d9c9618d4543de1dac (diff)
parent84b49be8f02aaf230164163a39c09049ed9f306d (diff)
downloadCMake-14c8096ba88502409f076cf0b0e5fe471c18f11b.zip
CMake-14c8096ba88502409f076cf0b0e5fe471c18f11b.tar.gz
CMake-14c8096ba88502409f076cf0b0e5fe471c18f11b.tar.bz2
Merge topic 'more-endif-closing-style-cleanups'
84b49be Remove CMake multiline block-end command arguments
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ae51697..230df63 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -804,9 +804,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
NOT "$ENV{COVFILE}" STREQUAL "" OR
CMAKE_RUN_LONG_TESTS)
set(CTEST_RUN_CPackTestAllGenerators ${CTEST_TEST_CPACK})
- endif(CMAKE_CXX_FLAGS MATCHES "-ftest-coverage" OR
- NOT "$ENV{COVFILE}" STREQUAL "" OR
- CMAKE_RUN_LONG_TESTS)
+ endif()
endif()
if(CTEST_RUN_CPackTestAllGenerators)
@@ -1227,9 +1225,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
"${CMake_BINARY_DIR}/Tests/SubDirSpaces/testfromsubdir.obj"
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/SubDirSpaces")
- endif (MAKE_IS_GNU OR
- "${CMAKE_TEST_MAKEPROGRAM}" MATCHES "nmake|gmake|wmake" OR
- "${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio|XCode|Borland")
+ endif ()
if (WIN32)
add_test(SubDir ${CMAKE_CTEST_COMMAND}