summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-28 21:34:34 (GMT)
committerBrad King <brad.king@kitware.com>2009-09-28 21:34:34 (GMT)
commit65a78ec5b81529507bed1375a13fca23bed60be7 (patch)
tree92499f72eb6092239b8bcf60438f7085a5bffe72 /Tests/CMakeLists.txt
parent0089f9cf8f0ff484b83b03d1fc11fbd2536d59b9 (diff)
downloadCMake-65a78ec5b81529507bed1375a13fca23bed60be7.zip
CMake-65a78ec5b81529507bed1375a13fca23bed60be7.tar.gz
CMake-65a78ec5b81529507bed1375a13fca23bed60be7.tar.bz2
Test support for OLD behavior of policy CMP0002
Policy CMP0002's OLD behavior allows duplicate non-custom targets. We test it with a project that builds two executables of the same name by setting CMP0002 to OLD.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ddebfc6..a9eb5a0 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -124,6 +124,9 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(ExportImport ExportImport)
ADD_TEST_MACRO(Unset Unset)
ADD_TEST_MACRO(PolicyScope PolicyScope)
+ IF("${CMAKE_TEST_GENERATOR}" MATCHES "Make")
+ ADD_TEST_MACRO(Policy0002 Policy0002)
+ ENDIF("${CMAKE_TEST_GENERATOR}" MATCHES "Make")
SET(CMAKE_BUILD_TEST_SOURCE_DIR "${CMake_SOURCE_DIR}/Tests/COnly")
SET(CMAKE_BUILD_TEST_BINARY_DIR "${CMake_BINARY_DIR}/Tests/CMakeBuildCOnly")