summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2012-05-01 21:00:43 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2012-05-01 21:00:43 (GMT)
commit7955e995ec400fb063529064b6232ca0eedfe5e0 (patch)
treebc3d928ad0b31dd93634794b83b425dfc8cdd8f7 /Tests/CMakeLists.txt
parenta86cd33cdd497acdb6b77a44c146a9779730675e (diff)
downloadCMake-7955e995ec400fb063529064b6232ca0eedfe5e0.zip
CMake-7955e995ec400fb063529064b6232ca0eedfe5e0.tar.gz
CMake-7955e995ec400fb063529064b6232ca0eedfe5e0.tar.bz2
Add support for Cache coverage.
This adds support for Cache coverage parsing. A test is added that does a basic run of the coverage on a small bit of data.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9a088e4..2cab695 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1726,6 +1726,22 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
set_tests_properties(CTestGTMCoverage PROPERTIES
PASS_REGULAR_EXPRESSION
"Process file.*XINDEX.m.*Total LOC:.*127.*Percentage Coverage: 85.83.*")
+
+ configure_file(
+ "${CMake_SOURCE_DIR}/Tests/MumpsCoverage/DartConfiguration.cache.tcl.in"
+ "${CMake_BINARY_DIR}/Testing/MumpsCacheCoverage/DartConfiguration.tcl")
+ configure_file(
+ "${CMake_SOURCE_DIR}/Tests/MumpsCoverage/cache_coverage.cmcov.in"
+ "${CMake_BINARY_DIR}/Testing/MumpsCacheCoverage/cache_coverage.cmcov")
+ file(COPY "${CMake_SOURCE_DIR}/Tests/MumpsCoverage/VistA-FOIA"
+ DESTINATION "${CMake_BINARY_DIR}/Testing/MumpsCacheCoverage")
+ add_test(NAME CTestCacheCoverage
+ WORKING_DIRECTORY "${CMake_BINARY_DIR}/Testing/MumpsCacheCoverage"
+ COMMAND
+ ${CMAKE_CTEST_COMMAND} -T Coverage --debug)
+ set_tests_properties(CTestCacheCoverage PROPERTIES
+ PASS_REGULAR_EXPRESSION
+ "Process file.*XINDEX.m.*Total LOC:.*125.*Percentage Coverage: 85.60.*")
# Use macro, not function so that build can still be driven by CMake 2.4.
# After 2.6 is required, this could be a function without the extra 'set'
# calls.